icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

routeos自动备份到FTP的代码

发表于 2015年05月15日 软路由版

# 自动备份到FTP


:local saveUserDb true;     # 是否保存用户数据库转储

:local saveSysBackup true;  # 是否保存整个系统备份

:local encryptSysBackup false; # 是否将系统备份(RouterOS的6.13及更高版本)加密

:local saveRawExport true;  # 无论是出口整体配置为纯文本.RSC脚本


:local myFtp "ftpserver.tld" # FTP服务器地址

:local myFtpPort 21          # FTP服务器端口


:local myFtpUser "my-mikrotik"      # FTP用户名

:local myFtpPass "SecurePassword"   # FTP密码


:local ts [/system clock get time]

:set ts ([:pick $ts 0 2].[:pick $ts 3 5].[:pick $ts 6 8])


:local ds [/system clock get date]

:set ds ([:pick $ds 7 11].[:pick $ds 0 3].[:pick $ds 4 6])


:local fname ("/BACKUP-".[/system identity get name]."-".$ds."-".$ts)


:if ($saveUserDb) do={

  /tool user-manager database save name=($fname.".umb")

  :log warning ("User Manager 数据库备份完成");

}


:if ($saveSysBackup) do={

:if ($encryptSysBackup) do={

  /system backup save name=($fname.".backup");

  }

  else={

    /system backup save name=($fname.".backup") dont-encrypt;

  }

:log warning ("系统备份完成");

}


if ($saveRawExport) do={

/export file=($fname.".rsc")

:log warning ("原配置脚本导出rsc文件完成");

}


:if ($saveUserDb) do={

/tool fetch address=$myFtp port=$myFtpPort src-path=($fname.".umb") user=$myFtpUser mode=ftp password=$myFtpPass dst-path=($fname.".umb") upload=yes

}


:if ($saveSysBackup) do={

/tool fetch address=$myFtp port=$myFtpPort src-path=($fname.".backup") user=$myFtpUser mode=ftp password=$myFtpPass dst-path=($fname.".backup") upload=yes

}


:if ($saveRawExport) do={

/tool fetch address=$myFtp port=$myFtpPort src-path=($fname.".rsc") user=$myFtpUser mode=ftp password=$myFtpPass dst-path=($fname.".rsc") upload=yes

}


:delay 5s;


:foreach i in=[/file find] do={:if ([:typeof [:find [/file get $i name] "BACKUP-"]]!="nil") do={/file remove $i}}

:log warning (成功删除临时备份文件")

:log warning (自动备份成功完成")


本文标题:routeos自动备份到FTP的代码
本文链接:http://www.hfycny.com/index.php/post/1015.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

名游彩票 www.929505.com-国家福彩中心彩赢家| www.ok85.com-河北快三最全走势图| www.bg74.com-辉煌彩票是骗局吗| www.711117.cc-彩纺织培训-| www.523583.com-时时彩怎么下载| www.32975.cc-苏州体彩竞彩店| www.001431.com-七星彩预测开门彩| www.82gj.com-天下彩678us| www.4710.com-身无分文买彩票发财| www.26779.cc-七星彩胆拖投注方式| www.444080.com-体育彩票nba玩法| www.640722.com-荣耀彩票app| www.731081.com-福彩邀请码-| www.525038.com-澳客彩票ios| www.616077.com-825彩票下载安装| www.700441.com-亚投彩票五分快三| www.805758.com-彩票属于什么职业| www.890530.com-彩票广东新快网| www.981247.com-彩票三星做号软件| www.fk37.com-分分彩预测器| www.e52.org-七星彩牛嗲头尾资料| www.700457.com-正投彩票大发快三| www.870309.com-天游彩票平台登录| www.9293.me-乐彩8603cc-| www.47mu.com-dt大通彩票手机版| www.0423.cc-福彩中奖彩票| www.6070.mobi-怎么辨别釉上彩| www.365486.com-彩铅简笔画完整兰花| www.512251.com-小清新手绘彩铅画| www.619927.com-彩色纸箱定制厂家| www.e54.com-竞彩篮球推荐网| www.652609.com-爱彩彩票网合法吗| www.741779.com-竞彩3串1技巧| www.41zs.com-今日头条老郑足彩| www.966.tv-举报明发彩票| www.1905.red-贵州多彩宝官方网站| www.01686.cc-福彩3d组选三复式| www.59yu.com-邯郸体彩加盟| www.2115.win-江苏彩票app下载| www.68678.cc-各大彩票一等奖概率| www.484878.com-北控京彩买彩票| www.804008.com-易彩计划软件手机版| www.893484.com-乐彩网破解器| 大赢家彩票网www.83033y.com| www.jx63.com-有靠买快三赚钱的吗| www.8511.in-福彩预测图字谜| www.35844.com-上海快三破解器| www.218576.com-彩票登陆-| www.44009.com-安装旺彩双色球软件| www.350934.com-查询鸿运彩票网| www.gy4.cc-福利彩票快三游戏| www.005854.com-怎样下载时时彩软件| www.114265.com-甘肃省快三推荐号| www.210181.com-伯爵国际彩票网站| www.511478.com-今日香港福利彩票| www.609638.com-腾讯分分彩四星秘密| www.8875.win-红旗彩票怎么下注| www.53534.com-丰和彩票-| www.055277.com-捕鱼送彩金-| www.171985.com-十分快三开奖结果| www.288325.com-11选五爱乐彩| www.437009.com-七星彩定位号| www.889643.com-网易三分彩走势图| www.964334.com-十四场胜负彩新浪| www.cp0417.com-福彩河北快三走势图| www.66484.com-广西快三和值表| www.470109.com-体彩多码遗漏| www.572383.com-刚利彩芽-| www.646399.com-竞彩水位口诀| www.715541.com-大公鸡七星彩赚钱吗| www.796836.com-足彩034期奖金| www.944821.com-248彩票网手机版| www.44934.com-华夏快三-| www.049547.com-彩票查询票-| www.3468.org-中彩快三计划| www.63664.com-足彩竞彩海外推荐| www.055173.com-微信黑彩-| www.447774.com-买足彩哪个软件好| www.17939.com-竞彩如何跟单更安全| www.18028.com-我要发彩网手机版| www.89547.com-快乐双彩开奖玩法| www.6689.pw-中国电脑福彩网| www.620610.com-庆重时时彩破解| www.299408.com-体彩排5今天开奖| www.nd87.com-大赢家彩票手机版| www.74vn.com-长沙中彩集团| www.4519.vip-帮我选一注彩票号码| www.638126.com-足彩网点-| www.920768.com-幸运5分彩是合法的| www.32ka.com-福利中奖彩票怎么看| www.382802.com-也买彩平台手机版| www.330052.com-福彩3d实时统计| www.330765.com-彩票助手追号计划| www.836211.com-88688彩票-| www.21fz.com-山西福利彩票块3| www.5220.top-实力彩票平台大全| www.447550.com-名人足彩公众号| www.539777.com-彩票后三跨度怎么玩| www.611184.com-开彩票店如何盈利| www.692981.com-福利彩票规律研究| www.790558.com-快三大最多连出多期| www.864239.com-最新彩票123| www.931848.com-中国体彩总部| www.983928.com-福彩天吉预测| www.xu1.com-湖北省福彩开奖| www.rm82.com-青海快三中奖规则| www.794040.com-公务员彩票-| www.791049.com-福彩快乐十分改版| www.938311.com-临海彩票案-| www.871118.com-旭彩美缝剂批发| www.736963.com-上海福利彩票投注站| www.525530.com-重庆彩票中心网站| www.0691.win-福彩投注站审批| www.888277.com-假彩票店-| www.8462.vip-七彩票今天开奖结果| www.46150.com-蛋蛋幸运彩票骗局| www.269536.com-彩九下载网站| www.358462.com-博仲彩票下载| www.456085.com-高频彩不要玩| www.548887.com-锋彩tv版直播| www.602643.com-上海彩票开奖号码| www.ct67.com-体彩大发快三| www.xp29.com-网易彩网app下载| www.28pt.com-7意彩网页版| www.393557.com-新浪彩网是骗人的吗| www.488238.com-彩票概率漏洞| www.550585.com-90后买彩票中大奖| www.614412.com-江苏快三怎么看和值| www.677933.com-彩票网站真假| www.737313.com-天下好彩天空彩| www.961137.com-福彩3d山东真言| www.bf01.cc-安徽快三走试图| www.993891.com-彩乐汇属于赌博吗| www.vq57.com-江苏快三看走势技巧| www.69vd.com-手机玩福彩-| www.3299.live-顶呱刮中奖彩票图片| www.330278.com-福建省福彩兑奖地点| www.438876.com-中国福利彩票站加盟| www.538453.com-大众彩票网骗局揭秘| www.657643.com-彩票双色球专家杀号| www.739257.com-亿发彩票官方下载| www.861532.com-立彩集团-| www.965572.com-体彩排列七开奖结果| 博友彩www.876295.com| www.or89.com-北京快三最长大小| www.25ye.com-海军迷彩图片| www.711.name-七星彩开彩结果| www.9386.biz-体育彩票买-| www.54339.com-彩票平台用抓包技术| www.041520.com-彩盈宝-| www.06au.com-儿童彩笔套装| www.8887.cn-给个靠谱的外围足彩| www.396198.com-彩虹包-| www.528365.com-最准彩票预测网| www.m77.club-彩票开奖内蒙快三| www.069797.com-福利彩票中奖图片| www.4726.vip-香港快乐十分彩| www.09kn.com-243彩票-| www.298218.com-玩快三赌博欠债| www.993542.com-足球彩票有几种玩法| www.19lm.com-肥城彩票三亿| www.182838.com-彩票选号神器| www.349026.com-天下第一彩票| www.830234.com-657彩票平台|