icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.hfycny.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

名游彩票 www.aj63.com-体彩481选号技巧| www.422799.com-申请福利彩票投注站| www.604144.com-688彩票例行审核| www.749116.com-中彩彩票注册账号| 创富彩票www.cf9902.com| www.39499.cc-卓易彩票老版| www.xa29.com-福彩快三是干嘛的| www.943.gg-六会彩和六星彩区别| www.02xk.com-阳光彩虹小白马原唱| www.372951.com-竞猜快三与快三区别| www.99ip.com-宝乐彩票我的账户| www.298660.com-qq彩票在哪里| www.218163.com-快三单双投注技巧| www.32895.com-江苏体彩即开| www.193156.com-福彩快三3开奖规律| www.603009.com-大学生团队购彩| www.286623.com-盛兴彩票骗局| www.m15.me-中国体彩排列三图迷| www.39xk.com-七星彩奇偶大小分析| www.5222.tv-派彩电子-| www.155.cm-彩虹天堂是什么意思| www.463777.com-福彩大厅开奖结果| www.700026.com-竞彩数据模型| www.867499.com-凤彩网双色字谜总汇| www.959935.com-大发快三定一码| www.332365.com-怎样黑彩票平台| www.9045.cn-南宁市福彩中心地址| www.81792.com-吉林快三系统故障| www.708228.com-状元彩票网安全吗| www.872330.com-贵阳体育彩票| www.ag08.com-彩票开奖结果哪里查| www.2342.in-天天中彩票注册3元| www.9067.loan-头彩app下载| www.77921.cc-幸运彩票旗下| www.828637.com-大树彩票-| www.na41.com-玩黑彩快三能赢钱吗| www.560397.com-糖果派对中彩金图片| www.234784.com-《中彩那天》课文| www.180201.com-福彩快三软件下载| www.53552.cc-彩票81软件-| www.171.in-好用的足彩外围| www.237986.com-內蒙古快三走势图| www.2620.cc-七零彩票-| www.62390.com-极速彩票技巧| www.96406.com-竞彩百度百科| www.273608.com-李永志彩票案结果| www.29826.cc-福彩现场直播| www.038098.cc-八9彩票-| www.032318.com-福彩三的图库| www.429480.com-福彩3d红五图库| www.563900.com-下载购彩助手| www.716781.com-彩铅手绘一棵樱花树| www.52662.cc-好彩门户网站| www.603103.com-彩虹6号禁播什么梗| www.861273.com-福彩双色珠中奖号码| www.ml02.com-北京快三怎么玩| www.126600.com-湖北彩票换球案| www.209233.com-爱乐彩贵州11选五| www.696562.com-新浪爱彩首页| www.774783.com-七星彩历史同期今天| www.855218.com-极速彩平台-| www.912520.com-好彩客把我害惨了| www.980213.com-梦想彩票登陆网址| www.eb37.com-破解易彩快三的方法| www.298331.com-内蒙快三有何规律| www.129072.com-手机上买彩票合法吗| www.531122.com-时时彩几把止损止盈| www.717091.com-顶级水彩颜料品牌| www.15bc.com-博恩彩之堂下载| www.663829.com-时时彩平台源码出租| www.41337.com-彩票挂机论坛| www.014922.com-七星彩分析口诀| www.123954.com-重庆快三是什么彩票| www.339723.com-新彩吧推荐号| www.456260.com-无需申请注册送彩金| www.694118.com-302彩票-| www.9301.vip-技术型彩民计算方法| www.38639.cc-彩运宝客服电话| www.78271.com-山西福彩3d走| www.092858.com-体彩61走势图| www.65lg.com-数字彩票竞技风暴| www.036672.com-赌快乐彩好方法| www.529236.com-彩票开奖假的| www.620356.com-御彩轩如何购买| www.56698.cc-北京快乐时时彩| www.45272.com-顶尖团队彩票计划| www.535959.com-七星体育彩票奖表| www.402565.com-3d福彩杀码图杀码| www.804937.com-七乐彩投注-| www.902071.com-玩黑彩坐庄能挣钱吗| www.982975.com-凡享饰家魔彩晶砖| www.88932.cc-彩678软件下载| www.oc05.com-极速时时彩开奖| www.29zi.com-福彩3d好中吗| www.136.win-饭圈彩虹屁英文| www.087315.com-彩票bug-| www.837525.com-立彩佳美缝剂好不好| 中彩网www.61233l.com| www.138302.com-互娱彩票是真的吗| www.260080.com-中国福彩3d助手| www.2456.net-大玩家彩票京东兑换| www.172871.com-广西快三今天开奖| www.136801.com-c99彩票平台| www.016959.com-黑彩票平台都有哪些| www.088645.com-福彩上海天天彩选四| www.151548.com-排五杀号定胆彩经网| www.515900.com-较好的足彩跟单软件| www.597300.com-尊彩是真的吗| www.642364.com-福彩背景图-| www.703382.com-万博彩票代理官网| www.770004.com-lbkeno快乐彩| www.823517.com-彩涂铝生产线| www.870451.com-彩票店怎么赚钱| www.909418.com-中国福彩网积分查询| www.69993.com-时时彩后二胆码计划| www.168978.com-内蒙古快三投注| www.134531.com-好彩香烟国内有卖吗| www.301287.com-新浪彩票全国开奖| www.701519.com-广西福利中奖彩票| www.766921.com-老凤凰彩票平台| www.822664.com-彩38源码下载| www.879228.com-8忆彩下载-| www.935127.com-信彩彩票靠谱吗| www.981146.com-八马彩票网站| www.bd84.com-三分彩怎么玩| www.865811.com-熊猫彩票是什么| www.950594.com-体彩胆码预测| www.521434.com-河北体彩申请投注站| www.77nr.com-山西福彩十分钟| www.805744.com-彩票汇总数据| www.22523.com-实体彩票店有前景吗| www.0250.loan-时时彩奖金对照| www.791614.com-马云入股彩票| www.667846.com-彩票论坛网址导航| www.661766.com-中国人福利彩票官网| www.255803.com-手机上如何投注彩票| www.50pw.com-今天七星彩开公告| www.458519.com-海南体彩平台| www.66792.cc-体彩的种类-| www.007821.com-腾讯彩票开奖查询| www.236953.com-竞彩310预测| www.304738.com-快三每个号-| www.328607.com-送彩金的棋牌游戏| www.303583.com-好彩网实力三肖八马| www.404414.com-白菜彩铅画教程| www.450480.com-三亚七星彩代理| www.573792.com-彩票中奖与数学| www.1564.pw-云彩宝彩票安全吗| www.34166.cc-福彩三d天中图库| www.123498.cc-是福彩好还是体彩好| www.83556.com-彩票大数据统计| www.120730.com-彩票走努图首页| www.182029.com-福彩快三新规定| www.247312.com-福彩快三时间更改| www.589584.com-七星彩有多少组号码| www.21538.com-彩票之家免费资料大| www.223970.com-浙江体彩6十1| www.874415.com-七t星彩开奖结果| www.0427.in-彩红兔同志-| www.370693.com-彩钢板门图片| www.526353.com-657彩票犯法不| www.594727.com-三彩羽绒服新款| www.789251.com-山西足彩5808| www.hl5.com-1分快3送彩金|